cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Madu" <andrewm...@gmail.com>
Subject Ambiguous Java class Import!
Date Tue, 20 Feb 2007 16:43:44 GMT
Hi,
I have just upgraded by Cocoon project from 2.1.9 to 2.1.10. No changes have
been made to the project code whatsoever and I am now getting the following
error message:

The process has failed due to InternalError: Ambiguous import: "[JavaClass
com.paypal.soap.api.DoDirectPaymentRequestType]" and and "[JavaClass
com.paypal.soap.api.DoDirectPaymentRequestType]". (file:/C:/Program
Files/jboss-4.0.3/server/default/./deploy/jbossweb-tomcat55.sar
/ROOT.war/beyarecords/flow/artist_new.js#283)

Again I state that there has been no code change from 2.1.9 to 2.1.10 and
the project works fine in 2.1.9. The import class, instantiation of class
and method calls are made from a flow document as so (abbreviated):

importClass(Packages.com.paypal.sdk.exceptions.PayPalException);
importClass(Packages.com.paypal.sdk.profiles.APIProfile);
importClass(Packages.com.paypal.sdk.profiles.ProfileFactory);
importClass(Packages.com.paypal.sdk.services.CallerServices);
importPackage(Packages.com.paypal.soap.api);

.....

var request = new DoDirectPaymentRequestType(); //this is line 283

Now, the only thing I can think that had changed from 2.1.9 to 2.1.10 is the
way packages are called i.e.:

importPackage(Packages.com.paypal.soap.api);

Other than that I am lost. Any ideas please?

--
Regards

Andrew

p.s.

Mime
View raw message