cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven D. Majewski" <sd...@virginia.edu>
Subject Re: continuation problem -- are id's unique ?
Date Mon, 05 Feb 2007 22:50:21 GMT

And when I fix the misspelling of "{flow-attr:alt_kont}" in the  
sitemap, the one I explicitly
passed works -- but that's not the current continuation -- that the  
one I bookmarked
right before the sendPageAndWait() call, so clicking on it just goes  
in a loop.

So passing a continuation explicitly in the use map works:

	var altcont = cocoon.createWebContinuation();	
	cocoon.sendPageAndWait( 'work/' + umap.instdir + '/' + umap.docbase  
+ '.aggregate',  { alt_kont:altcont.id } );

But I can't seem to get the cocoon.continuation.id  ( whether I use  
dots or slashes in the sitemap ).

-- Steve Majewski

On Feb 5, 2007, at 5:26 PM, Steven D. Majewski wrote:

>
> Oops: when I look at the source of the page, I see that those  
> href's are actually empty.
>
> 	<a href="" >
>
> Which the browser translates as a relative link to the current page.
>
> I don't know why it's NOT getting passed, but that at least makes  
> more sense than that the
> WRONG continuation was being passed!
>
>
> -- Steve Majewski
>
>
>
> On Feb 5, 2007, at 5:09 PM, Steven D. Majewski wrote:
>
>> That same identical URL is attached to both the links generated  
>> from the "kont" and "altkont"
>> params in the xslt transform.
>>
>>
>> That should NOT be what I'm seeing ? Right ?
>>
>> BTW: This is cocoon.2.1.9 running as a Tomcat servlet on Mac OSX  
>> 10.4.8
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message