cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Huttar <lars_hut...@sil.org>
Subject Re: Running Cocoon in debugger
Date Thu, 04 Jan 2007 20:08:41 GMT
P.S...

On 1/4/2007 12:03 PM, Grzegorz Kossakowski wrote:
> Lars Huttar napisaƂ(a):
>   
>> On 1/4/2007 8:19 AM, Grzegorz Kossakowski wrote:
>> Thanks for your quick reply. You are right of course about the port
>> number.
>> However the :8000 was just an email typo. When browsing to
>> http://localhost:8888/, the browser gives the above error ("No context
>> on this server matched or handled this request"). Browsing to
>> http://localhost:8000/ actually gives no error but causes Jetty to
>> shut down.
>>
>> So, I still have the same problem.
>> When I browse to http://localhost:8888/, Jetty outputs the following
>> message to the console:
>>    09:44:51.166 EVENT  Started HttpContext[/]
>> So I know Jetty is to some degree "catching" the request.
>> Also, I neglected to mention that the heading above "No context on
>> this server matched..." was "Error 404 - Not Found."
>>     
> It's odd. Which version of java do you have?
JDK 1.5.0_09.
>  Do you have something like
> this as output on jetty console:
> 18:48:40.007 EVENT  Started SocketListener on 0.0.0.0:8888
> 18:48:40.007 EVENT  Started org.mortbay.jetty.Server@1be0f0a
> ?
>
>   
I tried jetty in a fairly pristine install of Cocoon 2.1.9, and it 
worked fine (gave the above two EVENTs and Cocoon responded to the 
browser). So there's clearly something wrong with my Cocoon 2.1.7 / 
Jetty config. However, Cocoon 2.1.7 runs fine with Tomcat. So I must 
have done something to the Jetty bundled with Cocoon 2.1.7. However the 
Jetty config files (tools\jetty\**) are the same in both installations. 
There was a  difference such that under Cocoon 2.1.7, 
jetty\conf\main.xml had <Arg>/</Arg> where in 2.1.9 it had 
<Arg><SystemProperty name="context" default="/"/></Arg>. But even when I

tried changing the 2.1.7 file to conform to the 2.1.9 file, the error 
did not go away.

Maybe if I could correct the parsing error, jetty would work.

Lars


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message