cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Hertz <...@danhertz.com>
Subject Re: Cinclude file not found - why?
Date Tue, 12 Dec 2006 13:10:16 GMT
> this error is most probably caused by Cocoon 
> not getting back to the web server.

Thanks Jörg,

I tried it on a LINUX server with a cinclude (does NOT
work), and an iframe which sources the file (works).

Curiously, the cinclude works on a Windows machine (same
apache/mod_jk/php config)

> OK, so it is Cocoon handling the above browser request? 
> What URI does it use to "pass it off to Apache"?


I have a sub-sitemap with the following:

<map:match pattern="**getname.php*">
<map:read
src="getname.php{2}"mime-type="application/x-httpd-php"/>
</map:match>

I also tried:
<map:match pattern="**getname.php*">
<map:read src="http://myservername/myphp/getname.php{2} 
"mime-type="application/x-httpd-php"/>
</map:match>

In Apache I have a

SetEnvIf Request_URI "/*.php" no-jk
SetEnvIf Request_URI "/myphp/*.php" no-jk

which seems to do a good job at handling the php stuff (I
manage to use tinymce editor within cocoon this way)

I am NOT a developer, so, I apologize in advance if what I
say seems a bit amateurish.

I just don't understand what the difference is between an
iframe calling the URL (or typing it in the browser) -- 
which returns the expected result, and a cinclude which 
calls the external file (using http:// and
not the cocoon:/ protocol) -- which does not.

Thanks for helping me learn!

Dan



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message