cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lars Huttar <lars_hut...@sil.org>
Subject Re: SQL Server 2005?
Date Fri, 06 Oct 2006 15:32:17 GMT
Richard,
Thanks for your suggestion.
So you're saying that you had to load the driver using Class.forName() 
before trying to open a connection.
Where did you put this Java code? in the SQLTransformer class?

One hates to tack on custom Java modifications, but if it's the only way 
to get SQL Server 2005 working...

Did you also have that class listed in the load-class parameter in 
web.xml like this?
    <init-param>
      <param-name>load-class</param-name>
      <param-value>
        com.microsoft.sqlserver.jdbc.SQLServerDriver
       ...
     </param-value>
   </init-param>

If so, and Cocoon apparently didn't load it, I wonder if that represents 
a bug in Cocoon.

Thanks,
Lars



On 10/6/2006 6:48 AM, Richard de Oude wrote:
> Hi Lars,
>  
> Not sure if you found a solution to the problem listed here ... 
> http://www.mail-archive.com/users@cocoon.apache.org/msg35806.html
>  
> I had the same issue, and found the important piece was:
> /Class.forName("com.microsoft.sqlserver.jdbc.SQLServerDriver");
> /con = 
> java.sql.DriverManager.getConnection(getConnectionUrl(),sql_username,sql_password);
>       
>  
> Bye
> Richard
>  
>  


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message