cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From werner <wer...@gefi.at>
Subject Re: [poll] Java 5 as minimum requirement for Cocoon 2.2
Date Thu, 10 Aug 2006 10:18:31 GMT
Reinhard Poetz wrote:

>
> On dev@cocoon we have started to dicuss whether we can make Java 5 
> becoming the minimum requirement for Cocoon 2.2. Note that this 
> discussion is completly unrelated to Cocoon 2.1 which needs JDK 1.3.
>
> The arguments pro Java 5 which was officially releases almost 2 years 
> ago, are the support of generics, annotations, build-in JMX, simpler 
> loop syntax, and many small improvements to a lot of classes.
>
> As Cocoon 2.2 hasn't been released yet, there is no existing user 
> base. Hence people are not forced to use Java 5 just because of a new 
> patch release. We plan to do a release based on the 2.1.X branch 
> within the next months, which might be the last one of this series.
>
> The question now is whether making Java 5 the minimum requirement is a 
> hurdle for people who plan to migrate or not.
>
> Your opinion is appreciated!
>
+1

* Cocoon was always "next generation" technology. I think it's more fun 
for the developers to work with Java 5. Fun is an important factor in 
open source projects.
* It will take some time until a new stable Cocoon 2.2 will be out and 
it will take much more time until people have migrated their 
applications. The migration work has to be done anyway.

Regards
Werner



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message