cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Poetz <reinh...@apache.org>
Subject [poll] Java 5 as minimum requirement for Cocoon 2.2
Date Thu, 10 Aug 2006 09:32:50 GMT

On dev@cocoon we have started to dicuss whether we can make Java 5 becoming the 
minimum requirement for Cocoon 2.2. Note that this discussion is completly 
unrelated to Cocoon 2.1 which needs JDK 1.3.

The arguments pro Java 5 which was officially releases almost 2 years ago, are 
the support of generics, annotations, build-in JMX, simpler loop syntax, and 
many small improvements to a lot of classes.

As Cocoon 2.2 hasn't been released yet, there is no existing user base. Hence 
people are not forced to use Java 5 just because of a new patch release. We plan 
to do a release based on the 2.1.X branch within the next months, which might be 
the last one of this series.

The question now is whether making Java 5 the minimum requirement is a hurdle 
for people who plan to migrate or not.

Your opinion is appreciated!

-- 
Reinhard Pötz           Independent Consultant, Trainer & (IT)-Coach 

{Software Engineering, Open Source, Web Applications, Apache Cocoon}

                                        web(log): http://www.poetz.cc
--------------------------------------------------------------------

	

	
		
___________________________________________________________ 
Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message