cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phillip Soltan <psol...@adelphia.net>
Subject Re: Using Cocoon w/Eclipse and Tomcat
Date Tue, 16 May 2006 22:05:14 GMT
I do have the "session-fw" block added also.  I have all the 
dependencies that are listed in "block.properties".

Phillip Soltan

On May 16, 2006, at 2:34 PM, Antonio Gallardo wrote:

> Hi Phillips,
>
> If you include cocoon-xsp, you need also to include "session-fw" block.
>
> Best Regards,
>
> Antonio Gallardo.
>
> Phillip Soltan escribió:
>> Hello,
>>
>> Right now, all my development is geared towards J2EE.  I'm trying to 
>> standardize on Tomcat as my servlet container and Eclipse as my IDE.  
>> Unfortunately, Cocoon isn't working for me in that environment.  I 
>> can get a stripped-down version of Cocoon to work but as soon as I 
>> add the XSP and Database blocks, I get the following error:
>>
>> -------------
>> Message: Could not find component (key 
>> [org.apache.cocoon.webapps.session.ContextManager])
>>
>> Description: 
>> org.apache.avalon.framework.configuration.ConfigurationException: 
>> Could not load class 
>> org.apache.cocoon.webapps.session.components.ContextInputModule for 
>> component named 'session-context' at 
>> jndi:/localhost/cocoon-219/WEB-INF/cocoon.xconf:162:151
>>
>> Sender: org.apache.cocoon.servlet.CocoonServlet
>>
>> Source: Cocoon Servlet
>>
>> cause
>>
>> org.apache.avalon.framework.component.ComponentException: Could not 
>> find component (key 
>> [org.apache.cocoon.webapps.session.ContextManager])
>> ---------------
>>
>> The ContextInputModule is under 'WEB-INF/classes' so I don't know why 
>> Cocoon can't load it.  If I comment out the line in 'cocoon.xconf' 
>> that loads the ContextInputModule then the 'serverpages' generator 
>> doesn't work.  Everything works under Jetty but that doesn't help me 
>> since I need to deploy to Tomcat.
>>
>> I've seen this question asked before but there wasn't any response.  
>> Does anyone have any suggestions?  What IDE are Cocoon developers 
>> using?
>>
>> Here is what I'm using:
>> Tomcat 5.5.15
>> Java 1.5.0
>> Eclipse 3.1.2 w/MyEclipse 4.1.1 Workbench
>> Cocoon 2.1.8 and 2.1.9
>>
>>
>> Thanks,
>> Phillip Soltan
>> AAA WebPro
>> tel: 805.484.8864
>> email: psoltan@aaawebpro.biz
>> http://www.aaawebpro.biz
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message