cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: Existing XSP "not found" by Cocoon (only on Linux)
Date Sat, 04 Mar 2006 09:15:46 GMT
Jakob Fix wrote:

>Well, it's been quite a number of months that I didn't have time to
>look at this problem, but I just wanted to let the mailing list know
>that I've just solved this problem, and that it had nothing to do with
>the XSP files, but with the sitemap.xmap file.  A very embarassing and
>stupid typing mistake, however, in my defense I must say it wasn't
>easily spotted.
>
>wrong:
>...
><map:match type="regexp"
>pattern="highlight/bv/(.*)/(.*)/(ext|doc)/([^|]*)(\|[0-9]+)?.xml">
>  <map:generate src="highlight.xsp " type="serverpages">
>...
>
>correct:
>...
><map:match type="regexp"
>pattern="highlight/bv/(.*)/(.*)/(ext|doc)/([^|]*)(\|[0-9]+)?.xml">
>  <map:generate src="highlight.xsp" type="serverpages">
>...
>
>Can you spot it :-)  What surprises me most is that it worked like
>this on the Windows platform.
>  
>

<map:generate src="highlight.xsp "
<map:generate src="highlight.xsp"


Interesting! Should the value of @src be trimmed before? Can this be considered a cocoon bug?

Best Regards,

Antonio Gallardo.




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message