cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Larsen" <gary.lar...@envisn.com>
Subject RE: Problem running app in WebSphere
Date Fri, 31 Mar 2006 13:28:24 GMT
In case anyone (probably novice like me) has a similar problem here's what I
found out.

The Tomcat container is more forgiving than WebSphere as the errors were
fixed by correcting my code.  (I'm not sure why there would be a difference
as it appears the same jars are being used in both cases.)

1. A buried stylesheet was calling a template which did not exist causing
the transformer handler exception.

2. The stylesheets contained an <xsl:out> which must have been causing
problems with the I18N Transformer, not producing an exception but no
translations were being performed.

Gary

> -----Original Message-----
> From: Gary Larsen [mailto:gary.larsen@envisn.com]
> Sent: Thursday, March 23, 2006 10:34 AM
> To: users@cocoon.apache.org
> Subject: Problem running app in WebSphere
> 
> I'm attempting to run my Cocoon application (2.1.7) in WebSphere (6.0.2).
> 
> It seems to be very close after the advice found here on setting the
> WebSphere class loaders to PARENT_LAST.  There seems to be a couple
> problems, probably related.
> 
> When sending a page that relies on an XSL references with <xsl:include>
> the
> app throws an exception:
> 
> ERROR [WebContainer : 1] sitemap.handled-errors 2006-03-23 09:57:54,848 -
>  Unable to get transformer handler for file:/C:/Program
> Files/IBM/WebSphere/AppServer/profiles/default/installedApps/ENVISNWS1Node
> 01
> Cell/netvisn_war.ear/netvisn.war/site/stylesheets/content-base.xsl
> org.apache.cocoon.ProcessingException: Unable to get transformer handler
> for
> file:/C:/Program
> Files/IBM/WebSphere/AppServer/profiles/default/installedApps/ENVISNWS1Node
> 01
> Cell/netvisn_war.ear/netvisn.war/site/stylesheets/content-base.xsl:
> org.apache.excalibur.xml.xslt.XSLTProcessorException: Exception in
> creating
> Transform Handler
> 	at
> org.apache.cocoon.transformation.TraxTransformer.setup(TraxTransformer.jav
> a:
> 318)
> ....
> 
> The other problem is that the I18N translation transforms are not working.
> Everything works great in Tomcat 4.1.
> 
> Any ideas on this?
> 
> Thanks,
> Gary
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message