cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Vaterlaus <mvaterl...@gmail.com>
Subject Re: Tomcat5.5 and trailing slash on URL
Date Sun, 05 Feb 2006 18:46:09 GMT
Hi Gunter,

I stumbled over the same problem this week. Till now, I don't have a
clue what's the reason for this behavior. I am using tomcat 5.0.28 and
cocoon 2.1.8 on Suse Linux. cocoon is quite stripped down (no samples
et al) but the root sitemap is almost left unchanged. I guess the
problem has to do with cocoon and the sitemap on the root level.
Although I did not have time to check this out in a profound manner.

Cheers,

--mv


On 2/3/06, Gunter D'Hondt <gunter.dhondt@sofico.be> wrote:
> All,
>
> My Cocoon webapp works fine under Tomcat 4.x but now I'd like to deploy in
> under Tomcat5.5; it all works fine except that apparently Tomcat always
> adds an extra slash to the URL at the back; so if I type
>
> http://localhost:8080/cocoon/welcomepage
>
> it will enter the Cocoon sitemap with
>
> http://localhost:8080/cocoon/welcomepage/
>
> and ofcoz my pipeline matcher is "welcomepage"; has anybody else had this
> problem? I know I can fix it by changing the matcher to "welcomepage/" but
> then I'd have to change all my pipelines while I'd just want to use the
> URL that the user types in (maybe a configuration setting in Tomcat or
> something like that?)
>
> Any help is welcome,
>
> Gunter D'Hondt
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message