cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gilles <gilles.cebel...@ign.fr>
Subject extra-classpath issue ?
Date Wed, 22 Feb 2006 14:59:29 GMT
Hi,

I'm using cocoon 2.1.8 deployed under tomcat 5.5.15
My jdk is 1.5.0_06, my OS is Red Hat Enterprise Linux ES release 4

I wrote a cocoon based application whose files are located in a directory
/var/www/webapps/visumtd/ apart from the cocoon webapp directory 
which is located in /var/www/webapps/cocoon/. I mounted this application
through the mount-table mecanism and it works fine.

This web application needs some specific jar files to run and I want these jar
files to be located in the application file hierarchy, not in the cocoon
 webapp one.

I used the extra-classpath parameter in web.xml of cocoon webapp to specify
 the path to those jars :

----
  <init-param>
    <param-name> 
<param-value>/var/www/webapps/visumtd/WEB-INF/lib/visuMtd-v0.0.3_j2dk_1.5.0.jar:/var/www/webapps/visumtd/WEB-INF/lib/metadata-0.0.1.jar</param-value>
    </init-param>
----

but this had no effect and the classes of those jars are not known 
(ClassNotFoundException)

I tried to use the ParanoidCocoonServlet instead of the CocoonServlet as 
suggested in the web.xml comments but with no effects. I also tried to set
the value of the "init-classloader" parameter to true. Still with no effects.

Of course, when I put the jar files in the WEB-INF/lib/ directory of cocoon 
webapp, everything works fine...

I've browsed the cocoon-users list archives : it seems that some people meet 
the same problem, but I didn't found any answer.

Does anyone have an idea ?


Thanks,

Gilles





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message