cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonas Lundberg <my.name.is.h...@gmail.com>
Subject Re: Empty request params
Date Sat, 07 Jan 2006 08:07:45 GMT
Maybe it would be easier to help you, if you could more about how you
are trying to retrieve the request parameters in Cocoon?
For instance, in xquery, the syntax for multi-part requests is
different from other requests:

to get multi-part requests, whereas you write:
request:request-parameter("name", ())

to get normal requests:
request:request-parameter("name", "")

Regards
Hans

On 1/7/06, John Lianoglou <john@arachnedesign.net> wrote:
> As a follow-up, it seems my having included enctype="multipart/form-
> data" to the form is causing the problem; I've got some file uploads
> in there, so I really need this option.
>
> Meanwhile, I'm going to muck about in WEB-INF/web.xml ....
>
>
> jL
>
> On Jan 6, 2006, at 7:52 PM, John Lianoglou wrote:
>
> > Hey all, I'm at my wit's end with a little fiasco I'm experiencing
> > regarding an empty <h:requestParameters> block... I'm using the
> > "Liver Headers" firefox extension, and SEEING the POST parameters
> > going out of the browser... but, Cocoon-side, there seem to be no
> > request parameters.
> >
> > There are no redirects in the mix... can anyone think of any other
> > common "gotchas" that can lead to this sort of thing?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message