cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Gallardo <agalla...@agssa.net>
Subject Re: Error Compiling Cocoon 2.1.4
Date Sun, 29 Jan 2006 21:29:30 GMT
Christian Barth wrote:

>Hi!
>
>I just wanted to compile a WAR-File from the 2.1.4 sources under windows.
>
>I followed the instructions in the Docu
>http://cocoon.apache.org/2.1/installing/index.html#N10114
>
>But I get the following error:
>
>C:\cocoon-2.1.4\cocoon-2.1.4>build war
>Using Java from C:\j2sdk1.4.2_08
>Buildfile: build.xml
>
>prepare:
>======================================================================
>                 Apache Cocoon 2.1.4 [1999-2004]
>======================================================================
> Building with Apache Ant version 1.6.0 compiled on December 18 2003
>----------------------------------------------------------------------
> Using build file C:\cocoon-2.1.4\cocoon-2.1.4\build.xml
>----------------------------------------------------------------------
> Compiler options:
>   - debug ......... [on]
>   - optimize ...... [on]
>   - deprecation ... [off]
>======================================================================
>Created dir: C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4
>
>compile-core:
>Copying 40 files to C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4\classes
>Copied 70 empty directories to 37 empty directories under
>C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4\classes
>Created dir: C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4\mocks
>Compiling 1 source file to
>C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4\mocks
>Compiling 563 source files to
>C:\cocoon-2.1.4\cocoon-2.1.4\build\cocoon-2.1.4\classes
>C:\cocoon-2.1.4\cocoon-2.1.4\src\java\org\apache\cocoon\servlet\multipart\Mu
>ltipartHttpServletRequest.java:76:
>org.apache.cocoon.servlet.multipart.MultipartHttpServletRequest is not
>abstract and does not override abstract method getLocalPort() in
>javax.servlet.ServletRequest
>public class MultipartHttpServletRequest implements HttpServletRequest {
>       ^
>1 error
>  
>
Advise: Cocoon 2.1.4 needs servlet 2.2. Be sure you have not a newer 
version of the servlet.jar in your classpath.

Best Regards,

Antonio Gallardo.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message