cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Johnston <coc...@lojjic.net>
Subject Re: Flowscript error (ComponentSelector) for server app
Date Mon, 23 Jan 2006 14:48:48 GMT
Jason Johnston wrote:
> Derek Hohls wrote:
> 
>> I have an app that works fine on a development machine
>> (Cocoon 2.1.5, WindowsXP, Tomcat 4.1.x, JDK 1.4.x)
>>  
>> But when I upload it and try and run it on the server:
>> (Cocoon 2.1.5, UNIX, Tomcat 4.1.x, JDK 1.4.x)
>>  
>> I get the error:
>>  
>> ERROR   (2006-01-23) 11:38.25:783   [sitemap.handled-errors] 
>> (/cocoon215/inddb/db/editUser.do) Thread-20/PipelineNode: 
>> "resource://org/apache/cocoon/components/flow/javascript/Database.js", 
>> line 33: uncaught JavaScript exception: at editUser 
>> (file:/opt/jakarta-tomcat-4.1.18/webapps/cocoon215/inddb/script/user.js, 
>> Line 46)
>> at  
>> (file:/opt/jakarta-tomcat-4.1.18/webapps/cocoon215/inddb/script/user.js, 
>> Line 6)
>> at  
>> (resource://org/apache/cocoon/components/flow/javascript/Database.js, 
>> Line 33):
>> org.apache.avalon.framework.service.ServiceException: datasources: 
>> ComponentSelector could not find the component for hint [inddb] (key 
>> [inddb]) 
>> (Key='org.apache.avalon.excalibur.datasource.DataSourceComponentSelector/inddb')

>>
>>  
>> How to interpret the "ComponentSelector could not find the component"
>> error message - what is the software looking for??
> 
> 
> This means it is trying to look up the Avalon component for that key, 
> and failing for some reason.  Key-to-component mappings are generally 
> defined in cocoon.xconf.
> 
>>  
>> (I am also not sure where the :
>> org/apache/cocoon/components/flow/javascript/Database.js
>> file is located... its not under WEB-INF/classes/... ?)
> 
> 
> Doing a quick search it looks like Database.js is part of the Petstore 
> sample block: 
> /src/blocks/petstore/trunk/java/org/apache/cocoon/components/flow/javascript/Database.js

> 
> 
> Is your application perhaps relying on this file for some reason, but 
> the Petstore block didn't get built in the version on your server?

Bah, nevermind that, of course the file is there if the error is 
occurring within it. ;-)

My guess now is that your datasource configuration from cocoon.xconf did 
not get copied over to the server.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message