cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toby <tobia.confo...@linux.it>
Subject Cocoon + MySQL Connector => Tomcat hangs?
Date Fri, 02 Dec 2005 17:40:31 GMT
Hi all

I'm trying to get a basic Tomcat + Cocoon + MySQL Connector setup to
work, but I'm experiencing a weird lockup!

My setup (latest stable versions of everything, but read on):

	Fedora Core 4
	Linux 2.6.11-1.1369_FC4smp SMP x86_64
	2x Intel Xeon CPU 3.00GHz

	Sun jdk-1_5_0_05-linux-amd64.bin
	Apache Tomcat 5.5.12
	Cocoon 2.1.8
	mysql-connector-java-3.0.17-ga

The only unusual feature here is the x86_64 architecture, but that very
'amd64' 1.5 JDK has compiled and run anything I've thrown at it so far,
so I don't suppose that's the problem.

I've tried running it all from scratch, without any of Fedora's or
JPackage's RPMs and with the right JAVA_HOME, but the problem remains:

    -  Java works, Cocoon builds without a hitch, plain Tomcat starts

    -  Tomcat + MySQL Connector work: a simple JSP can talk to MySQL

    -  Tomcat + Cocoon work: I can browse the sample sitemaps and XSPs

but!

    X  Tomcat + Cocoon + MySQL Connector  *don't even start!*

They hang just after printing the following line to catalina.out:

	INFO [main] (QuartzScheduler.java:399) - Scheduler
			Cocoon_$_Fri_Dec_02_16:00:29_CET_2005 started.

I have attached a longer piece of log below.
They hang if there is a MySQL Connector jar in either Tomcat's or
Cocoon's lib directory AND I load com.mysql.jdbc.Driver in web.xml.

That is, if I remove the connector jar Tomcat starts and Cocoon works
(except for SQL) as they do if I disable the connector in Cocoon's
web.xml.  In which case the connector still works from a standalone JSP.


Am I missing something basic here?
Should I give up trying to get stuff to work on x86_64?
Is it an incompatibility between some of the software versions?
I have tried many more version combinations than this one, but I can't
remember them all.  

I am open to any suggestion and advice: feel free to ask for specific
tests or anything else.


Toby


------------ RELEVANT PART OF CATALINA.OUT ------------

Dec 2, 2005 3:38:35 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Portable Runtime which allows optimal performance in production environments
was not found on the java.library.path: /opt/jdk1.5.0_05/jre/lib/amd64/server:/opt/jdk1.5.0_05/jre/lib/amd64:/opt/jdk1.5.0_05/jre/../lib/amd64
Dec 2, 2005 3:38:35 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Dec 2, 2005 3:38:35 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 866 ms
Dec 2, 2005 3:38:35 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Dec 2, 2005 3:38:35 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.12
Dec 2, 2005 3:38:35 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
 INFO [main] (FacesConfigurator.java:139) - Reading standard config org/apache/myfaces/resource/standard-faces-config.xml
 INFO [main] (FacesConfigurator.java:295) - faces-config.xml found in jar /WEB-INF/lib/cocoon-faces-block.jar
 INFO [main] (FacesConfigurator.java:347) - Reading config /WEB-INF/faces-config.xml
 INFO [main] (StartupServletContextListener.java:80) - ServletContext '/opt/tomcat-5.5.12/webapps/cocoon/'
initialized.
 WARN [main] (XindiceServlet.java:147) - The database 'db' root directory has been set to
/srv/disk2/cocoon/WEB-INF/db. Keep in mind that if a war upgrade will take place the database
will be lost.
 INFO [main] (Database.java:262) - Database points to /srv/disk2/cocoon/WEB-INF/db
 INFO [main] (XindiceServlet.java:167) - Database 'db' successfully opened
 INFO [main] (XindiceServlet.java:205) - Xindice server successfully started
trying to register database
trying to register database
 INFO [main] (QuartzScheduler.java:194) - Quartz Scheduler v.1.5.0 created.
 INFO [main] (RAMJobStore.java:138) - RAMJobStore initialized.
 INFO [main] (DirectSchedulerFactory.java:331) - Quartz scheduler 'Cocoon
 INFO [main] (DirectSchedulerFactory.java:333) - Quartz scheduler version: 1.5.0
 INFO [main] (QuartzScheduler.java:399) - Scheduler Cocoon_$_Fri_Dec_02_15:38:46_CET_2005
started.

------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message