cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geert Josten <Geert.Jos...@daidalos.nl>
Subject Re: [Fwd: [Chaperon-users] wiki grammer]
Date Mon, 05 Sep 2005 20:30:33 GMT
Hi Oliver,

Not dead, but there aren't lots of people asking questions, so we might doze off from time
to 
time... ;-)

Contrary to all the other answers, I'll focus on the actual question, because I believe it
is still 
unanswered, while the answer to it is, to my humble opinion, actually quite simple.

The Wiki grammar that is shipped with Chaperon is written such that it allows a top-level
title, 
followed by sub-level titles and between those subsub-level titles (intermingled with paragraphs
and 
such). However, no grammar rule is added to support subsub-level titles directly underneath
a 
top-level title, which means you are actually skipping a section level.

So you could say that Chaperon is quite strict, but actually it is the grammar that is not
accepting 
the wiki file you supply. Change the wiki grammar to make it work.

I expect that somewhere in some logfile there is a message that will state that a subsubtitle
token 
is not expected at that point. Though, the error message itself might be a little less clear
about 
it.. :-P

Cheers,
Geert

Oliver Schalch wrote:

> Seems like really dead on the Chaperon List...
> 
> 
> -------- Original Message --------
> Subject: [Chaperon-users] wiki grammer
> Date: Thu, 25 Aug 2005 11:33:14 +0200
> From: Oliver Schalch <oliver.schalch@wyona.com>
> Reply-To: chaperon-users@lists.sourceforge.net
> To: chaperon-users@lists.sourceforge.net
> 
> Hi all,
> 
> We are building a publication for Lenya, where we can use and make Wiki
> Documents. Therefor we use some parts from Chaperon/Cocoon, now the wiki
> Syntax have some strange behavior, and I want to ask if anyone
> noticed similar behavior or know where I should go look more into...
> 
> If I write a normal wiki document like:
> !!! Bigtitle
> !! A bit smaller
> ! Smal...
> ...
> ...
> that works fine but when I insert the ! tag between !!! and !! tags then
> nothing will be shown.
> It looks like that it have problems just with the ! someTitle, because
> if you want start the document with !, also
> nothing will be displayed.
> 
> Looks like issues in the grammer (wiki.grm or generation of wiki.xgrm),
> or what do you think?
> 
> 
> Greetings
> Oli

-- 
Drs. G.P.H. Josten


Daidalos BV
Source of Innovation
Hoekeindsehof 1-4
2665  JZ  Bleiswijk
tel: +31 (0) 10 850 1200
fax: +31 (0) 10 850 1199
http://www.daidalos.nl


De informatie - verzonden in of met dit emailbericht - is afkomstig van Daidalos BV en is

uitsluitend bestemd voor de geadresseerde. Indien u dit bericht onbedoeld hebt ontvangen,
verzoeken 
wij u het te verwijderen. Aan dit bericht kunnen geen rechten worden ontleend.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message