cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AD Marshall <admarsh...@gmail.com>
Subject Re: BUILD FAILED: Could not create task... : if
Date Fri, 19 Aug 2005 15:37:22 GMT
thanks JD, i'll try this first, then maybe Ivan's suggestion,
if i still don't have a solution necessary. (it's late here already) 

I forgot to mention that the layout section in the 
forrest.properties file shipped with cocoon 2.1.7 has 
uncommented entries (unlike forrest) that don't point to the
intuitively appropriate paths under src/documentation (like
those in the forrest 0.7 forrest.properties do).  

I tried adjusting them once, but didn't understand some 
entries and it didn't seem to help. And cocoon seems to 
build a "dummy" site first, populate it with part of the 
overall build and then use that partial build for a complete
build (the "blocks" technique, i think).  

Should i have to hack the forrest.properties file or any of
the *build.xml files? 


On 8/19/05, JD Daniels <jd@kismetsoftware.com> wrote:
> well heres a more useful reply...
> 
> somewhere in your build is:
> 
> <if>
>         <istrue value="${some.property}"/>
>         <then>
>                 <dosomething/>
>         </then>
> </if>
> 
> You need the ant-contrib for the <if> to work.
> 
> http://ant-contrib.sourceforge.net/
> 
> JD
> 
> 
> JD Daniels wrote:
> > sounds like you need to add the ant-contrib jar to your ant classpath
> >
> > JD
> >
> >
> > AD Marshall wrote:
> >
> >> Can anyone suggest a solution or reference for the following issue?
> >>
> >> I'm repeatedly getting this message from cocoon's build.sh under SuSE
> >> Linux 9.3:
> >>
> >> BUILD FAILED
> >> /home/am/bin/cocoon-2.1.7/tools/targets/compile-build.xml:244: The
> >> following error occurred while executing this line:
> >> /home/am/bin/cocoon-2.1.7/build/cocoon-2.1.7/temp/blocks-build.xml:373:
> >> Could not create task or type of type: if.
> >>
> >> (Umm, "if"?!?  That's the weirdest error message i've seen to date.
> >> Anyway...)
> >>
> >> I looked into the manual and blocks-build.xml (as build.sh's output
> >> advises), but couldn't figure out what the problem is.
> >>
> >> Before running build.sh, i checked my JAVA_HOME and ANT_HOME (and
> >> others) -- ant supposedly being part of my SuSE 9.3 installation:
> >> $ env | grep _HOME
> >> FORREST_HOME=/home/am/bin/apache-forrest-0.7
> >> JRE_HOME=/usr/lib/jvm/java/jre
> >> JAVA_HOME=/usr/lib/jvm/java
> >> SDK_HOME=/usr/lib/jvm/java
> >> JDK_HOME=/usr/lib/jvm/java
> >>
> >> I "unset FORREST_HOME" -- after noting cocoon included some "calls" to
> >> forrest and fiddling with FORREST_HOME -- and tried again.  Same
> >> error.
> >>
> >> I've included the complete output from build.sh from my latest attempt
> >> (below my eSig').
> >>
> >> Any suggestions?
> >>
> >> Thanks,
> >> Andi
> >>
> >> PS: I don't have a regular Net connexion.  So it might be day or two
> >> before i see any replies. But i *will* get to any that come.
> >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> > For additional commands, e-mail: users-help@cocoon.apache.org
> >
> >
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
> 
> 


-- 
AD (Andi) Marshall
Cell: +84 (0)903871313
eM: admarshall@gmail.com
Zone: ICT (IndoChina Time, GMT/UTC+7)
Post: HoChiMinh City (ex/or SaiGon), VietNam

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message