cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Burling <...@umich.edu>
Subject Strange problem upgrading Tomcat/Cocoon
Date Wed, 03 Aug 2005 16:26:03 GMT
I'm starting the process of upgrading our Tomcat/Cocoon install, currently 
Tomcat 5.0.16 and Cocoon 2.1.3, wanting to move to Tomcat 5.5.9 and Cocoon 
2.1.7.  I've run into a problem that I can't explain, and hope that someone 
else has seen (and solved!) the problem.

Our web/Tomcat/Cocoon server is a Sun ES3500, running Solaris 8 (uname says 
SunOS hostname 5.8 Generic_117350-25 sun4u sparc).  A vanilla install of 
Tomcat, with an un-modified server.xml, starts up just fine.  If I copy the 
cocoon.war file that results from un-tarring the Cocoon 2.1.7 distribution 
and typing "build.sh war" into Tomcat's webapps directory, the Tomcat 
startup hangs right after logging "Scheduler 
Cocoon_$_Wed_Aug_03_11:26:06_EDT_2005 started."

I've done this install on two other test machines, one a Dell box running 
Red Hat Enterprise AS 4.1, and one another Sun box running the same version 
of Solaris as the problem box.  Both installs work fine, and Tomcat starts 
up fine with Cocoon installed.  So I'm completely mystified.

I've attempted to find any reference to this problem in the list archives 
and via Google, and did find one post that claims that Cocoon and Tomcat 
5.5 simply aren't compatible, but my tests show that it works fine 
everywhere I've tried it *except* on our production server.  Any help would 
be greatly appreciated.

-- 
Steve Burling                                    <mailto:srb@umich.edu>
University of Michigan, ICPSR                    Voice: +1 734 615.3779
330 Packard Street                               FAX:   +1 734 647.8700
Ann Arbor, MI 48104-2910

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message