cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@odoko.co.uk>
Subject Re: [SOLVED] Re: Mysql connection error
Date Wed, 13 Jul 2005 14:34:44 GMT
Derek Hohls wrote:
> Quick follow-up.
> 
> I check with the admin staff and the mysql client had been
> installed and so was able to test the permissions as per 
> your guidelines - that worked and I was also able to  run 
> my  query OK.
> 
> So I figured there must be a problem with the Cocoon
> setup... somewhere.  I went back to that "old" IBM
> tutorial [really needs updating!] and found this in the
> install section:
> 
> "check that the driver has been properly installed and loaded.
> Restart Tomcat to ensure that all classes are properly reloaded. 
> Once Tomcat and Cocoon 2 have restarted, check the 
> $COCOON_HOME/WEB-INF/logs/access.log
> file for an entry similar to the following:
> (Unknown-URI) Unknown-thread/CocoonServlet:
> Trying to load class: org.hsqldb.jdbcDriver
> This indicates that the server is attempting to load the driver. 
> If a java.lang.ClassNotFoundException has been logged after 
> this message, then the driver is not correctly installed."
> 
> I did and sure enough - there was the ClassNotFoundException !
> 
> On double-checking I found the mysql driver file was not in
> the lib directory... I think that between my starting on this
> problem (yesterday) and these latest tests, the version of 
> Ccooon had been upgraded - and the "extra" jar was not
> reinstalled - what a waste of a day!
> 
> Thanks again, though, for the patient support. I continue to learn;
> albeit at a painful pace.

Well done for fixing it.

That is the nature of these problems - they're brutally obvious, once 
you've fixed them :-)

Regards, Upayavira

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message