cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Ratcliffe <a...@prema.co.nz>
Subject Re: mysql error
Date Fri, 01 Apr 2005 22:08:45 GMT
I wasn't aware that the mysql driver was included with the Cocoon  
distro.

To add a new driver put the driver JAR file in your  
<webapp-root>/WEB-INF/lib directory,
declare the driver in web.xml and define the datasource in cocoon.xconf  
if you haven't done
so already.

HTH
Adam

On 1 Apr, 2005, at 11:19 PM, Mygrp wrote:

> hi,
>
> i get the following exception when trying to connect to mysql db using  
> jdbc.
> java.lang.AbstractMethodError:
> org.gjt.mm.mysql.Connection.createStatement(II)Ljava/sql/Statement;
>
> This error is seen only when i use
> stmt =  
> con.createStatement(ResultSet.TYPE_SCROLL_SENSITIVE,ResultSet.CONCUR_RE 
> AD_ONLY);
>
> No error is seen for stmt = con.createStatement()
>
> Is this because cocoon mysql driver does not support
> TYPE_SCROLL_SENSITIVE and CONCUR_READ_ONLY.
>
> How can the driver be updated? which directory should it be updated?
>
> thanks in advance
> md
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message