cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carsten Ziegeler <cziege...@apache.org>
Subject Re: Global Question to cocoon and Java 1.5
Date Tue, 08 Mar 2005 13:11:17 GMT
I'm trying to see what I can do about it - hopefully 2.1.7 will then
compile with 1.5 out-of-the-box.

Thanks for the infos!

Carsten

Martinson, Theresa wrote:
> In an email last month, there was a similar question.
> (Subject was: target release 1.3 conflicts with default source release
> 1.5)
> 
> We do use 1.5, but had to tweak things a little.
> 
> 
> I will include last month's email response here:
> 
> We also had to do minor tweaks to the following java classes to get this
> to compile:
> *	DocumentWrapper.java
> *	DateMetaInputModule.java
> *	IteratorHelper.java
> *	XPointerFrameworkParser.java
> *	StatusGenerator.java
> *	EnumerationFactory.java
> 
> 
> For example - in EnumerationFactory, change the parameter name in the
> relevant methods from "enum" (a new reserved word) to "en".
> 
> Modified code snippet for EnumerationFactory:
>  /**
>    * Order relations Object.op (OtherObject) representing the relation
>    * Object op OtherObject.
>    * @param en the right operand
>    */
>   public boolean lt (EnumerationFactory en) {                   // "<"
>     return this.getPos() < en.getPos ();
>   }
>   public boolean le (EnumerationFactory en) {                   // "<="
>     return this.getPos() <= en.getPos ();
>   }
>   public boolean gt (EnumerationFactory en) {                   // ">"
>     return this.getPos() > en.getPos ();
>   }
>   public boolean ge (EnumerationFactory en) {                   // ">="
>     return this.getPos() >= en.getPos ();
>   }
> 
> 
> Theresa 
> 
> 
> 
> Michel Erard wrote: 
> 
>>Subject: Global Question to cocoon and Java 1.5
> 
> 
>>Does someone using cocoon and Java 1.5 on Windows? I think it is not
> 
> possible to compile cocoon witz this version of java, >becaus the
> Interface org.w3c.dom.Document was expanded from version 1.4.2 to 1.5.0
> and contains currently more methods, >which are'n implementet by cocoons
> classes. F. ex. by the class org.apache.cocoon.xml.dom.DocumentWrapper
> which implements >this Interface.
> 
> 
>>On Linux i do not have this problem... and I'm wondering about this...
> 
> 
>>Mike
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
> 
> 
> 


-- 
Carsten Ziegeler - Open Source Group, S&N AG
http://www.s-und-n.de
http://www.osoco.org/weblogs/rael/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message