cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From es <es....@javanet.info>
Subject problem deploying ImageReader: produce no image
Date Mon, 07 Mar 2005 18:03:55 GMT
Dear all,
I'm trying ImageReader class for scaling down images. I'm using the 
example that comes with http://cocoongallery.sourceforge.net and it runs 
fine locally.
However, when I deploy it on the public server, it reply with a 0 lenght 
image file. You can check it by your self here
http://equobio.org/c/gallery/album1/image-h48-image-115-1587_IMG.jpg
it maps to a requested for an image with height 48pixel (the dogs of 
Peter Gerstbach author of cocoongallery example)
http://equobio.org/c/gallery/album1/image-image-115-1587_IMG.jpg
locally works on the server it doesn't.

I initially suspected was due to the fact no X was installed, so I tried 
   appending -Djava.awt.headless=true to CATALINA_OPTS env, installing 
xfree-commons and Xlibs, and even using PJA but with the same result.

I turned sitemap logging to DEBUG and I attached the output for a 
request. Unfortunatly no error is present.
No errors in other logs :/

I have tried also to comment width and height parameter in <map:read but 
it does't change. always 0 lenght image.

What should I try to debug this problem?
thanks in advance
Eli




Mime
View raw message