cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adriano Smith <orosm...@sify.com>
Subject wml doctype
Date Mon, 07 Mar 2005 12:04:14 GMT
is it compulsory to have the doctype and xml version for a wml page?

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
"http://www.wapforum.org/DTD/wml_1.1.xml">

if i try to ignore the above declaration in the wml page and validate the wml in a wml validator
there is no error. However an error occurs if i include the above lines in the wml code.

So i ignored the doctype and version declaration by commenting the lines on the sitemap and
tested the wml page on the pda, the page doesnt load though.

Can anyone please help me and tell me as to y this happens and can i ignore the declaration??

thanks

 
Mime
View raw message