cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier RICHAUD" <oliv...@richaud.net>
Subject RE : Migrating from Cocoon 2.0.x to 2.1.3
Date Thu, 10 Mar 2005 21:07:21 GMT
Thanks.

It's a classloader problem. Jboss shares classes among applications !
And a previous version of commons-lang is present elsewhere.

Many thanks for your help.

-----Message d'origine-----
De : news [mailto:news@sea.gmane.org] De la part de Gregor J. Rothfuss
Envoyé : mercredi 9 mars 2005 20:41
À : users@cocoon.apache.org
Objet : Re: Migrating from Cocoon 2.0.x to 2.1.3


Olivier RICHAUD wrote:

> I'm upgrading our Cocoon application to Cocoon 2.1.3 and I'm facing 
> some

why not 2.1.6?

> weird errors with XSP. When calling a very simple XSP page 
> (simple.xsp), I get the following exception (SystemUtils is packaged 
> in
> commons-lang-2.0-20041007T2305.jar) :

> java.lang.NoSuchMethodError: 
> org.apache.commons.lang.SystemUtils.isJavaVersionAtLeast(I)Z

> My environment :
> 	Jboss 3.2.3 with Jetty

looks like a class loading problem. jboss probably has its own copy of 
commons lang. try moving commons-lang into endorsed

-- 
Gregor J. Rothfuss
COO, Wyona       Content Management Solutions    http://wyona.com
Apache Lenya                              http://lenya.apache.org
gregor.rothfuss@wyona.com                       gregor@apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message