cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier RICHAUD" <oliv...@richaud.net>
Subject Migrating from Cocoon 2.0.x to 2.1.3
Date Wed, 09 Mar 2005 11:06:59 GMT
Hi all,

I'm upgrading our Cocoon application to Cocoon 2.1.3 and I'm facing some
weird errors with XSP. When calling a very simple XSP page (simple.xsp),
I get the following exception (SystemUtils is packaged in
commons-lang-2.0-20041007T2305.jar) :

java.lang.NoSuchMethodError:
org.apache.commons.lang.SystemUtils.isJavaVersionAtLeast(I)Z
        at
org.apache.cocoon.components.notification.DefaultNotifyingBuilder.append
TraceChain(DefaultNotifyingBuilder.ja
va:160)
        at
org.apache.cocoon.components.notification.DefaultNotifyingBuilder.build(
DefaultNotifyingBuilder.java:103)
        at
org.apache.cocoon.components.notification.DefaultNotifyingBuilder.build(
DefaultNotifyingBuilder.java:136)
        at
org.apache.cocoon.servlet.CocoonServlet.manageException(CocoonServlet.ja
va:1266)
        at
org.apache.cocoon.servlet.CocoonServlet.service(CocoonServlet.java:1166)
        ...

I'm not hacking my previous sitemap. Instead, I started from the sitemap
that comes with Cocoon's distribution (see attachement). 

My environment :
	Jboss 3.2.3 with Jetty
	JDK 1.4.2
	Windows XP

Thanks for your help.

Regards.


Olivier RICHAUD.

Mime
View raw message