cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jason_co...@hti.htch.com
Subject JSR-168 portlets content resetting?
Date Fri, 25 Feb 2005 06:28:01 GMT
I've been trying to get JSR-168 portlets working inside Cocoon.  I've 
gotten the pluto testsuite portlet rendering and working.  I've gotten the 
Cocoon JSR-168 portlet working.  All the links within a portlet seem to 
work as expected.  However, right now, clicking a link on any portlet will 
cause all JSR-168 portlets on the page to "reset" to whatever their 
default content is for whatever mode they are in. 

For example, on the JSR-168 tab in the sample portlet which shows the two 
portlets from the pluto testsuite, if I run a test in portlet one, so it 
is displaying the test results as content, then run a test in portlet two, 
when portlet two displays its test results, portlet one will display the 
list of available tests (it's "default" content) rather than the test 
results that it had been displaying prior to clicking the link in portlet 
two.

This happens if I click a link in a CachingURIPortlet on a page as well. 
Any JSR-168 portlets on the page have content reset.  However, if I click 
a link in the JSR-168 portlet, the content in the CachingURIPortlet does 
not change.  The only time this does not happen is if the portlet is in a 
different mode (e.g., help or edit).  The content stays (although, I don't 
have a portlet with multiple displays in those modes; it's possible they'd 
reset to whatever the default content of the current mode is, I suppose).

All JSR-168 portlets involved reside outside the cocoon webapp that is 
running the portal, in other webapps on the same server.

If I try the same behavior on a page rendered by the pluto reference 
implementation web application using the exact same portlets (same server, 
same web applications), they work as I'd expect.  One JSR-168 portlet's 
content doesn't get "reset" when another's is changed.

I'm hoping this behavior is due to some configuration tweak I'm missing. 
I'm having this happen both with Cocoon 2.1.6 (using a pluto-1.0.1-rc2 
build) and a 2.1.x version pulled from Subversion on Wednesday.  I'm using 
Tomcat 5.0.28 as my server.  Any suggestions?

I've tried uncommenting anything related to marshalling JSR168 events in 
cocoon.xconf, but without any success.  All the other code is vanilla; I 
haven't changed any of the profiles/coplet*/portal.xml files or the 
WEB-INF/portlet.xml files in the other applications.  If samples from 
those files would be helpful, let me know.

Thanks!

Jaes 
Mime
View raw message