cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christina Cunningham <christina.cunning...@qub.ac.uk>
Subject Disappearing namespace attributes
Date Thu, 10 Feb 2005 10:27:56 GMT
Hi,

I am using cocoon forms (version 2.1.4) to load a template xml file, 
fill-in / edit details, and then bind the data back to the xml file. The 
problem I am having is that the namespace declarations in the root 
element are disappearing when the data is saved to the result file.

In the data that is loaded up for display, the root element is

<manifest xmlns="http://www.pro-mpeg.org/md/manifest/0.25" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://www.pro-mpeg.org/md/manifest/0.25">

In the data-result file, the root element is

<manifest xsi:schemaLocation="http://www.pro-mpeg.org/md/manifest/0.25">

I don't want any of the namespace attributes to change so they weren't 
referenced in the bindings etc. but as an attempted work around, I tried 
binding the namespaces back to the form but got the same result.

I am using rh9 and tomcat 4.1.27. Has anyone any suggestions as to what 
I should look at to resolve this issue?

Thanks

Christina

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message