cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Driftmeyer <mdr...@yahoo.com>
Subject Re: RE : 2.1.6 build problem
Date Thu, 17 Feb 2005 20:27:49 GMT
The clue is here:

C:\cocoon2.1.6\tools\targets\init-build.xml:159:

    <!-- compile the ant tasks -->
    <mkdir dir="${tools.tasks.dest}"/>
    <javac srcdir="${tools.tasks.src}"
           destdir="${tools.tasks.dest}"
           debug="off"
           optimize="on"
           deprecation="on"
           target="1.5"
           nowarn="on"
           compiler="${compiler}"
           classpathref="tasks.classpath"/>

    <!--<javac srcdir="${tools.tasks.src}"
           destdir="${tools.tasks.dest}"
           debug="off"
           optimize="on"
           deprecation="on"
           target="1.3"
           nowarn="on"
           compiler="${compiler}"
           classpathref="tasks.classpath"/> -->


Note the comments:  Replaced target="1.3" with target="1.5"

Second edit of init-build.xml

    <!-- compile the loader, used to change classpath especially for
           the CLI and Jetty -->
    <mkdir dir="${tools.loader.dest}"/>
    <javac srcdir="${tools.loader.src}"
           destdir="${tools.loader.dest}"
           debug="off"
           optimize="on"
           deprecation="on"
           target="1.5"
           nowarn="on"
           compiler="${compiler}"/>

    <!-- <javac srcdir="${tools.loader.src}"
           destdir="${tools.loader.dest}"
           debug="off"
           optimize="on"
           deprecation="on"
           target="1.3"
           nowarn="on"
           compiler="${compiler}"/> -->

Note the comments:  Replaced target="1.3" with target="1.5"

It will fail on the first target conflict so both need to be updated. 
I hope there will be a more elegant solution in the future but this
works for me on Debian Linux and I expect it will work for you on XP.

--- EXT / STAGIAIRE PLASSE Cédric (DSIT-EX/2i)
<ext.stagiaire.plasse@sncf.fr> wrote:

> In the file build.properties you have this parameter : source.vm=1.3.
> You
> can try to change this value to 1.5 but I don't know if it works. You
> cannot
> modify directly the file build.properties. You have to make a copy of
> this
> file renamed "local.build.properties" as explained in
> build.properties.
> 
> 
> -----Message d'origine-----
> De : Gunter D'Hondt [mailto:gunter.dhondt@sofico.be] 
> Envoyé : jeudi 17 février 2005 16:13
> À : users@cocoon.apache.org
> Objet : 2.1.6 build problem
> 
> 
> Hi,
> 
> jdk1.5, tomcat5.5, cocoon2.1.6
> 
> 
> --------------
> C:\cocoon2.1.6>build
> Buildfile: build.xml
> 
> init-tasks:
> Compiling 5 source files to C:\cocoon2.1.6\tools\anttasks
> javac: target release 1.3 conflicts with default source release 1.5
> 
> BUILD FAILED
> C:\cocoon2.1.6\tools\targets\init-build.xml:159: Compile failed; see
> the 
> compiler error output for details.
> 
> Total time: 1 second.
> --------------
> 
> 
> Anybody an idea?
> Regards,
> Gunter D'Hondt
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
> 
> 



		
__________________________________ 
Do you Yahoo!? 
Yahoo! Mail - Find what you need with new enhanced search.
http://info.mail.yahoo.com/mail_250

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message