cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lundquist <mlundqui...@comcast.net>
Subject Problem w/ flow & internal redirects (Cocoon 2.1.6)
Date Thu, 27 Jan 2005 01:42:07 GMT
Hi, I'm having trouble figuring out this problem...

I have a flowscript that displays a form using form.showForm(), does 
its thing, and calls cocoon.sendForm().

  The Problem:

If I submit an invalid form, the request invoked by sendForm() gives me 
"No pipeline matched request."!  This is the same request that was 
processed the first time through to display the form, but for some 
reason it misses in the sitemap the second time when the form is being 
redisplayed!

If I submit a valid form, then I get the same "No pipeline matched 
request" for the final sendPage() of the flowscript.  So, it's like 
internal redirects after the continuation is resumed are broken, or 
something.

The flowscript is being called from a subsitemap, if that matters.

I set sitemap logging to DEBUG, but that didn't turn up any clues.  
Obviously it's something I'm doing, because forms+flow in a subsitemap 
work just fine in the samples...  BTW this application worked w/ Cocoon 
2.1.5... but I might have made a few other changes since porting it to 
2.1.6, before I became aware of this problem.

Any ideas where I might look to try and debug this?
Thanks a lot!
—ml—


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message