cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ugo Cei <>
Subject Re: [flow] Hibernate createCriteria syntax help?
Date Thu, 27 Jan 2005 17:38:42 GMT
Il giorno 27/gen/05, alle 15:16, JD Daniels ha scritto:

> right? Or would it be better to have one class such as BugFacade with 
> all methods dealing with bugs? (save, find, delete etc)

Yes, that is usually preferrable. A class that deals with retrieving 
and storing domain objects to a persitent store is usually called a 
Data Access Object (DAO).

> Lastly, I am pretty sure the above would work, but to be really 
> separate-y, what about:
> var bugSearch = new 
> var bean = bugSearch.findBugById(id);

What's changed WRT to the previous version? I can't see the difference.


Ugo Cei -

View raw message