cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <Ralph.Go...@dslextreme.com>
Subject Re: javaflow on weblogic 8.1sp2
Date Thu, 27 Jan 2005 15:38:18 GMT
WHIRLYCOTT wrote:

> I'm trying to get javaflow from Cocoon 2.1.5.1 working Weblogic 8.1sp2 
> with the application deployed as a .war file (i.e. not exploded) 
> without much luck.  I tweaked the ParanoidCocoonServlet so that it is 
> loading jars out of /WEB-INF/lib/ (easy to do, but you need to use the 
> Servlet 2.3 jar, not the 2.2 jar that Cocoon normally builds against).
>
> I see posts out there on the cocoon-users list indicating that people 
> have approximately this config working...?
>
> I seem to be bumping into an initialization problem with the 
> JavaInterpreter.  It's calling ContinuationClassLoader.initialize(), 
> which then throws a java.lang.NoSuchMethodError when trying to do 
> Repository.setRepository() (that's in the BCEL jar).
>
> Ideas, prayers and samples from working configurations would be 
> greatly appreciated ;)
>
> phil.

Weblogic.jar has its own versions of Rhino and BCEL in it.  You can try 
to get the Cocoon versions to supercede them but then you might run into 
failures in other parts of Weblogic.  We switch to Java flow just 
because of this.

Ralph

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message