cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saulius Grigaliƫnas <saulius.grigaliu...@gmail.com>
Subject form encoding and utf-8 problems
Date Sun, 23 Jan 2005 09:12:05 GMT
Hello there cocoon community,

I've got some strange problems with form submiting and utf-8 encoding,
so i'm trying to write something in utf-8 in my form ( try it yourself
- http://dev.vzg.lt/Add/ ) and see what has been submited. After
submit I get some strange and really non utf-8 characters, what am I
doing wrong?

Here is the full configuration:

Pipeline
              <map:match pattern="Add/">
                     <map:generate type="file" src="storage/xml/test.xml"/>
                     <map:transform type="xslt-saxon"
src="stylesheets/nauja.xsl" />
                     <map:serialize type="xhtml" />
              </map:match>
              <map:match pattern="Add/item">
                     <map:generate type="serverpages"
src="logic/xsp/addnews.xml"/>
                     <map:serialize type="xml" />
              </map:match>

Serializers:
              <map:serializer name="xhtml" mime-type="text/html;
charset=UTF-8" src="org.apache.cocoon.serialization.XMLSerializer">
                     <doctype-public>-//W3C//DTD XHTML 1.0
Strict//EN</doctype-public>
                    
<doctype-system>http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd</doctype-system>
                     <omit-xml-declaration>yes</omit-xml-declaration>
                     <encoding>UTF-8</encoding>
                     <omit-namespaces>yes</omit-namespaces>
                     <indent>yes</indent>
              </map:serializer>
              <map:serializer name="xml"
src="org.apache.cocoon.serialization.XMLSerializer" 
mime-type="text/xml" logger="sitemap.serializer.xml"  pool-grow="4"
pool-max="32" pool-min="4">
                     <encoding>UTF-8</encoding>
              </map:serializer>

And simple xsp file content:
<page>
<xsp-request:get-character-encoding />
<br />
<xsp-request:get-parameter name="body" />
</page>
</xsp:page>

In web.xml I've got..
    <init-param>
      <param-name>container-encoding</param-name>
      <param-value>UTF-8</param-value>
    </init-param>
    <init-param>
      <param-name>form-encoding</param-name>
      <param-value>UTF-8</param-value>
    </init-param>

Cocoon 2.1.6 with Tomcat 5.0.30. So I guess this is it, looking
forward to your answers!

-- 
Saulius

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message