cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph Goers" <Ralph.Go...@dslextreme.com>
Subject RE: Exception in thread "main" java.lang.NoClassDefFoundError: Lo ader
Date Thu, 02 Dec 2004 17:14:16 GMT

I'm sorry, I must have been very tired when I read your prior email. My
comments were about problems running build.sh, not cocoon.sh.

In 2.1, Cocoon is released in source distributions, not binary
distributions. This means you have to build it before you can run it.  The
error you are getting happens if you untar the distribution and then run
cocoon.sh without having built cocoon.  You must run ./build.sh first. 
This is mentioned briefly on the download page. If you care, a good
discussion on why Cocoon has no binary distribution can be found at
http://wiki.apache.org/cocoon/LatestRelease.

Ralph

Brian McGovern said:
> I followed these instructions and still get the same error.  To reiterate
> the problem.  Ive installed cocoon but cannot start it via
>
> bash~# ./cocoon.sh
>
> I get the following error
> java.lang.NoClassDefFoundError: Loader
>
>  My Env is
>    jakarta-tomcat-5.0.28
>    cocoon-2.1.5.1
>    j2sdk1.4.2_05
>
>
> Any ideas?
>
> Thanks


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message