cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnson" <john...@soho.club.tw>
Subject Re: [HOW-TO] Compile Cocoon 2.1.6 using java 1.5 --amand-ok
Date Fri, 10 Dec 2004 13:59:56 GMT
got the blocks-build.xml from!

in src/blocks-build.xsl
just like before add a source="1.4" line to javac block

best regards

johnson

----- Original Message ----- 
From: "Johnson" <johnson@soho.club.tw>
To: <users@cocoon.apache.org>
Sent: Friday, December 10, 2004 7:01 PM
Subject: Re: [HOW-TO] Compile Cocoon 2.1.6 using java 1.5 --amand-ok


> Hi!
>
> I add a line in javac command source="1.4" in the init_build.xml 
> compile-build.xml samples-build.xml
> change the target="1.3" to target="1.4" in init_build.xml
> and I build cocoon 2.1.x with java 1.5 twice.
> once there will a file blocks-build.xml in build/cocoon-2.1.x/tmp
> replace all target="${target.vm}" p with target="${target.vm}" 
> source="1.4" p
> and build again,it ok.
> I'm wondering where the blocks-build.xml established.
>
> Best Regards
>
> johnson
>
>
> ----- Original Message ----- 
> From: "Johnson" <johnson@soho.club.tw>
> To: <users@cocoon.apache.org>
> Sent: Thursday, December 09, 2004 8:33 PM
> Subject: Re: [HOW-TO] Compile Cocoon 2.1.6 using java 1.5
>
>
>> Supplementary info!
>>
>> Because  Java language in 5.0, enum is now a keyword and can no longer be 
>> used as an identifier.
>> So must add a line  "source=1.4" below target="1.5".
>> more info pls see http://java.sun.com/j2se/1.5.0/compatibility.html
>>
>> Best Regards
>>
>> Johnson
>>
>> ----- Original Message ----- 
>> From: "Antonio Gallardo" <agallardo@agssa.net>
>> To: <users@cocoon.apache.org>
>> Sent: Monday, November 29, 2004 11:06 PM
>> Subject: [HOW-TO] Compile Cocoon 2.1.6 using java 1.5
>>
>>
>>> Hi:
>>>
>>> I read a lot of mails asking if cocoon 2.1.6 is compilable and runnable
>>> using java 1.5.
>>>
>>> The short answer is yes. Unfortunately, we need to make 2 changes:
>>>
>>> Edit the file: $COCOON_HOME/tools/targets/init-build.xml
>>>
>>> and changes lines 156 and 182:
>>>
>>> target="1.3" ----> target="1.5"
>>>
>>> I hope this help.
>>>
>>> That is all!
>>>
>>> Best Regards,
>>>
>>> Antonio Gallardo
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message