cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Hess <p...@posi.de>
Subject Cocoon with JNDI Datasource in Weblogic
Date Fri, 12 Nov 2004 13:55:22 GMT

Hi,

I have a feeling that this question is not exactly Cocoon related but 
I'll try anyway...

We have a Cocoon application deployed on Weblogic 7 since a couple of 
month. Now I would like to add some functionality which requires access 
to our Oracle database. There is already a datasource defined in 
Weblogic which is used by another web application (CMS). This CMS works 
fine so the Datasource seems to be allright.

I tried to make this datasource available in Cocoon but until now I 
failed. I tried accessing the database using JDBC works but that's not 
what I want - I want the datasource.

What I did before:

- Datasource in Weblogic 7 is called "CMS-DataSource"
- I added this section to cocoon.xconf:

	<datasources>

		<j2ee name="CocoonDS">
			<dbname>CMS-DataSource</dbname>
		</j2ee>

		<jdbc ...>
			(section to test JDBC way follows, works fine)
		</jdbc>
	</datasources>

- for the SQL transformer I'm using in the sitemap:

	<map:transform type="sql">
		<map:parameter name="use-connection" value="CocoonDS" />
		...
	</map:transform>

This does not work, I'm getting an error message:

	Initialization Problem
	Message: null
	Description: No details available.
	Sender: org.apache.cocoon.servlet.CocoonServlet
	Source: Cocoon Servlet
	cause
	Unable to resolve 'app/webapp/csr/12914246/comp/env/jdbc/CocoonDS' 
Resolved: 	'app/webapp/csr/12914246/comp/env' Unresolved:'jdbc'


After some more searching I found some references on web.xml's 
<resource-env()-ref> and weblogic.xml's <res-ref-name>
config elements but my tests all failed and fear I'm not getting the 
concept here.

Maybe somebody can point me in the right direction and bring me back on 
track here. Thanks for help and have a nice weekend ;)

Patrick
	




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message