cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leszek Gawron <lgaw...@mobilebox.pl>
Subject Re: Encoding problems, still!
Date Mon, 01 Nov 2004 13:18:12 GMT
Philip.Fennell@empolis.com wrote:
> I have just recently resolved a problem with fragment identifiers in URLs for pages that
are served-up by Cocoon in UTF-8 to IE 6 on the PC.
> 
> My sitemap was set-up to deliver XHTML in UTF-8 and IE understood this. However, if I
sent a request that had a fragment identifier on the end:
> 
> http://myserver/document/path/document.html#SL12345
> 
> IE ignored #SL12345 and did not scroll the page to the single instance of the specified
id in the target document.
> 
> But, when I followed the instructions in:
> 
> http://wiki.apache.org/cocoon/RequestParameterEncoding
> 
> regarding explicitly setting the Servlet container-encoding in Cocoon's web.xml it all
worked happily :)
This is quite strange for me as your anchor name contains only basic 
ascii characters SL12345. Are you sure that was the cause for problem?

> I just thought people should know this.
> 
> Should I add it to the afore mentioned wiki?
Sure

-- 
Leszek Gawron                                      lgawron@mobilebox.pl
Project Manager                                    MobileBox sp. z o.o.
+48 (61) 855 06 67                              http://www.mobilebox.pl
mobile: +48 (501) 720 812                       fax: +48 (61) 853 29 65

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message