cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Gallardo" <agalla...@agssa.net>
Subject Re: Cocoon 2.1.6 and Java 1.5.0
Date Tue, 23 Nov 2004 04:29:32 GMT
Hi:

I am able to run the 2.1.6 with java 1.5.

Talking about "official compatibility"... I think it is too early to
speak. Why? Because few people tested it. I am not using java 1.5 for my
development environment. I am only "playing" with java 1.5 on time to
time.

There are also some issues to be solved. One of them is the XSP compiler
support for java 1.5.

AFAIK, currently the only compiler with full support for java 1.5 is the
sun compiler (javac shipped in java 1.5). We shipped cocoon 2.1.6 with
eclipse compiler (version 3.0.1) by default. The eclipse compiler still
have not java 1.5 support. The eclipse community will ship the java 1.5
support in version 3.1 (Release date? Who knows.).

As you can see, we still cannot talk about a "full 1.5 compatibility", but
we already did some proggress in that ;-)

The other big problem is that AFAIK, there is no java 1.5 for Mac's and we
have a lot of people using Mac.... And this is one of the BIG advantages
using a Intel machine! ;-)

/me hopping to not start a flame war style: Mac vs. Intel :-)

BTW, on the SVN there is already a fix for the problem reported by
Christian Rosenberger.

If you need more help, please let us know. ;-)

Hope this help.

Best Regards,

Antonio Gallardo.

Miha ┬Žetina dijo:
> I would also like to know the answer to this.
> I have tried to compile it over the weekend and it does not end at this.
> You
> can change target versions in init-build.xml from 1.3 to 1.5, but then
> comes
> the rest.
> 1.5.0 comes with (probably) new dom classes. Next thing I encountered was
> the DocumentWrapper class which is missing some abstract members from
> Document and Node classes.
>
> Regards , Miha ┬Žetina
> MiGA d.o.o.
> 1000 Ljubljana
> tel: 01/5819242
> fax: 01/5819241
>
> ----- Original Message -----
> From: "Christian Rosenberger" <piepermail@gmx.de>
> To: <users@cocoon.apache.org>
> Sent: Sunday, November 21, 2004 4:53 PM
> Subject: Cocoon 2.1.6 and Java 1.5.0
>
>
>> Hi,
>>
>> is the new Cocoon version 2.1.6 compatible to Java SDK 1.5.0?
>>
>> At my debian server the build process failed:
>>
>> #:/opt/cocoon-2.1.6# export JAVA_HOME=/usr/java/1.5.0/
>> #:/opt/cocoon-2.1.6# ./build.sh
>> Buildfile: build.xml
>>
>> init-tasks:
>> Compiling 5 source files to /opt/cocoon-2.1.6/tools/anttasks
>> javac: target release 1.3 conflicts with default source release 1.5
>>
>> BUILD FAILED
>> /opt/cocoon-2.1.6/tools/targets/init-build.xml:159: Compile failed; see
>> the comp
>> iler error output for details.
>>
>> Total time: 1 second
>>
>> Which version of Cocoon will have built-in-support for 1.5.0?
>>
>> Any solution? The mails in the archive said, that this was fixed with
>> current CVS version. (before 2.1.6 release)
>>
>> Regards,
>> Christian Rosenberger
>>
>>
>>
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
>>
>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.796 / Virus Database: 540 - Release Date: 13.11.2004
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message