cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andres Taborda <antabo...@yahoo.com>
Subject procedure for configure saxon cocoon 2.1.6
Date Tue, 30 Nov 2004 03:59:07 GMT
hello list
some users can help me for configure and test
saxon 8.1

I have problems when use saxon:assign extension of
saxon, my xsl not recognize the tag.

I first copy the saxon8.jat to lib/local and
uncomments
the section of cocoon.xconf for saxon, after addition 
el match for sitemap.

this are file. 

<?xml version="1.0" encoding="UTF-8"?>
<p>Hello</p>



<?xml version="1.0"?>
<xsl:stylesheet
    xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    version="2.0"
>

<xsl:template match="p">
   <xsl:apply-templates/><hr/>


   <xsl:variable name="i" select="0"
saxon:assignable="yes"
xmlns:saxon="http://sf.net/saxon"/>
   The value of i is <xsl:value-of select="$i"/>




      <saxon:while test="$i &lt; 10"
xmlns:saxon="http://sf.net/saxon">
          El valor es  <xsl:value-of select="$i"/>
         <saxon:assign name="i" select="$i+1"/>

      </saxon:while>


</xsl:template>

</xsl:stylesheet>



the message of error is saxon:attribute not recognize.



_________________________________________________________
Do You Yahoo!?
Información de Estados Unidos y América Latina, en Yahoo! Noticias.
Visítanos en http://noticias.espanol.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message