cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean Pierre LeJacq <jplej...@quoininc.com>
Subject RE: Cocoon 2.1.5.1 and BEA Weblogic 8.1 SP3
Date Thu, 21 Oct 2004 22:35:19 GMT
On Fri, 22 Oct 2004, Christian Rosenberger wrote:

> is there anyone out there, who uses the current BEA weblogic server with
> the current Cocoon version?

I've built and run cocoon 2.1.5.1 with WebLogic 8.1sp2.  No real
problems except if you have to use different versions of xalan and
xerces than the one bundled with WebLogic.


> There are two ways, I deployed Cocoon - both not working:
>
> 1. Build Cocoon as web archive directory (build.sh webapp)
>
> If I want to access the first cocoon page
> (http://localhost:7001/cocoon/), I get a error message "Resource not
> found".

This looks like cocoon is executing.  Did your sitemap and content
files get copied over?  Try modifying the sitemap to serve a simple
static html page.


> 2. Build Cocoon as war archive (build.sh war)
>
> In this case, I get an other error message: "Initialization failed".
> Stacktrace:
> org.apache.avalon.framework.context.ContextException: The hsqldb cannot
> be used inside a WAR file.

As the error clearly says, you cannot run hsqldb inside a war.  I
haven't found a way around this.

-- 
JP



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message