cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From beyaNet <and...@jibeya.com>
Subject Re: Urgent! cocoon.createSession() not working in 2.1.5.1
Date Fri, 29 Oct 2004 10:06:44 GMT
Hi,
it seems the cause of my problem is the RewriteRule lines I have 
specified in my Apache http.conf file. In my workers2.properties file I 
have the following line:

[uri:/cocoon/mysite/*] (note: cocoon/mysite is situated inside JBoss 
4.0.0 as 
/server/default/deploy/jbossweb-tomcat50.sar/cocoon.war/mysite)
group=lb

which enables me to access my website via :80 by saying:

http://www.mysite.com/cocoon/mysite/login.xml

Doing this works fine and you can browse from one page to another and 
all sessions are maintained. The problem starts when I try and do:

http://www.mysite.com/login.xml

which I have catered for in my http.conf file by defining a number of 
RewriteRule lines:

RewriteEngine on

RewriteRule (.*)\.xml$ cocoon/mysite/$1.xml [P]
RewriteRule (.*)\.xsl$ cocoon/mysite/$1.xsl [P]
RewriteRule (.*)\.kont$ cocoon/mysite/$1.kont [P]
RewriteRule (.*)\.jxt$ cocoon/mysite/$1.jxt [P]
RewriteRule (.*)\.xsp$ cocoon/mysite/$1.xsp [P]
RewriteRule (.*)\.css$ cocoon/mysite/$1.css [P]
RewriteRule (.*)\.js$ cocoon/mysite/$1.js [P]
RewriteRule (.*)\.mp3$ cocoon/mysite/$1.mp3 [P]
RewriteRule (.*)\.m3u$ cocoon/mysite/$1.m3u [P]
RewriteRule (.*)\.jpg$ cocoon/mysite/$1.jpg [P]

When I type in http://www.mysite.com/login.xml the page loads fine, and 
in the process creates a session to maintain flow global variables. 
When you then try and select any other page which requires you to have 
been logged in first, it seems the page has lost scope/context/domain! 
and acts a if you have come to the site for the first time and so 
redirects you straight back to the login.xml page. But as I have said 
before typing http://www.mysite.com/cocoon/mysite/login.xml works fine 
and I can navigate from page to page no problem.

Does anybody have a solution for this?

many thanks in advance

Andrew


On 28 Oct 2004, at 16:19, beyaNet wrote:

> Does anybody have any experiences/solutions on this issue?
>
> regards
>
>
> Andrew
> On 27 Oct 2004, at 21:03, beyaNet wrote:
>
>> Hi,
>> I am running cocoon 2.1.5.1 in JBoss 4.0 like so:
>>
>> /server/default/deploy/jbossweb-tomcat50.sar/cocoon.war
>>
>> i have a website which uses simple MVC using flowscript. I originally 
>> developed the system under tomcat alone using cocoon 2.1.4 which 
>> worked fine. I copied the cocoon folder and placed it in the above 
>> mentioned directory in JBoss. Now flowscript does not work. I have a 
>> few global variables which I make persistent by initiating 
>> cocoon.createSession(), but when I move from page to page and try and 
>> grab the values from those global variables they all have a null 
>> value. What is going on here? Is anybody else experiencing this under 
>> 2.1.5.1 using JBoss 4.0? Any input on this issue is urgently 
>> required.
>>
>> many thanks
>>
>>
>> Andrew
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
>> For additional commands, e-mail: users-help@cocoon.apache.org
>>
>>
> <beya-email.gif>
>  +The home of urban music
>  + http://www.beyarecords.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> For additional commands, e-mail: users-help@cocoon.apache.org

Mime
View raw message