cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Doms" <a...@inf.tu-dresden.de>
Subject AW: build cocoon with Java5 alias Java 1.5
Date Thu, 14 Oct 2004 21:12:11 GMT
I added the "-source 1.4" option into all ant build files (also for the
javadoc tags)
The errors in the one deprecated source I fixed by renaming a local variable
from enum to enumeration.

> -----Urspr√ľngliche Nachricht-----
> Von: Ray Allis [mailto:rayallis@comcast.net]
> Gesendet: Donnerstag, 14. Oktober 2004 19:11
> An: ad11@inf.tu-dresden.de
> Cc: users@cocoon.apache.org
> Betreff: Re: build cocoon with Java5 alias Java 1.5
> 
> I asked this same question a week ago.  Let me know what you find out.  I
> am
> not planning to revert to java 1.4.
> 
> > init-tasks:
> > Compiling 12 source files to /export/home/ray/cocoon-2.1/tools/anttasks
> > javac: target release 1.3 conflicts with default source release 1.5
> 
> 
> Andreas Doms wrote:
> 
> > I get compiler error because in some sources the enum keyword is used as
> > an identifier.
> > I tried to add the "-source 1.4" option into the ant build but I still
> > get errors when compiling the deprecated sources.
> >
> > cocoon version 2.1.5.1 was used.
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
> > For additional commands, e-mail: users-help@cocoon.apache.org
> >
> >


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message