cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Rosenberger" <christian.rosenber...@gmx.net>
Subject RE: Cocoon 2.1.5.1 and BEA Weblogic 8.1 SP3
Date Fri, 22 Oct 2004 08:39:16 GMT

Hi,

Thanks for your quick answer.

Jean Pierre LeJacq wrote:

>> is there anyone out there, who uses the current BEA weblogic server 
>> with the current Cocoon version?

>I've built and run cocoon 2.1.5.1 with WebLogic 8.1sp2.  No real
problems except if you have to use different versions of xalan and
xerces than the one 
>bundled with WebLogic.

What do you use for deployment? The web console? Did you copy the Cocoon
directory to Weblogic subdir?


> There are two ways, I deployed Cocoon - both not working:
>
> 1. Build Cocoon as web archive directory (build.sh webapp)
>
> If I want to access the first cocoon page 
> (http://localhost:7001/cocoon/), I get a error message "Resource not 
> found".

This looks like cocoon is executing.  Did your sitemap and content files
get copied over?  Try modifying the sitemap to serve a simple static
html page.

I've done just the standard cocoon build and defined this directory (in
/home/xyz/cocoon/build/...) as a new webapp in Weblogic. If I start the
integrated Jetty container, all works fine. (also no error message at
build time)

>> 2. Build Cocoon as war archive (build.sh war)
>>
>> In this case, I get an other error message: "Initialization failed".
>> Stacktrace:
>> org.apache.avalon.framework.context.ContextException: The hsqldb 
>> cannot be used inside a WAR file.

>As the error clearly says, you cannot run hsqldb inside a war.  I
haven't found a way around this.

Ok. I thought, maybe there's a way around this.

Christian


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message