cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorg Heymans ...@domek.be>
Subject Re: Cocoon 2.0.4 still failing
Date Thu, 09 Sep 2004 14:43:28 GMT
try "build webapp" as target. But how on earth you're getting the 
instantiationexception i don't know...

Peter Flynn wrote:

> On Thu, 2004-09-09 at 13:25, Jorg Heymans wrote:
> 
>>>
>>>>Any particular reason why you decided on an old cocoon version?
>>>
>>>
>>>Yes, Cocoon 2.1.5.1 won't compile because ant is apparently
>>>being picked up wrongly from FC2, despite what the docs say;
>>>and Tomcat 5.5 has issues running under Java 1.5.0 unless
>>>you start adding patches.
>>
>>If you're looking to use cocoon professionally, you should seriously 
>>consider using 2.1.5.1 - the 2.0.x branch is not actively maintained 
>>anymore (for over a year). Java 1.5 is not yet supported by cocoon so 
>>don't worry about tomcat just yet.
> 
> 
> I've tried and tried, but 2.1.5.1 build.sh simply doesn't work.
> I removed the ant distributed with FC2 from RPM, despite the fact that
> it's clear from build.sh that it never goes anywhere near it, but uses
> the ant distributed with Cocoon 2.1.5.1 instead. Now I get
> 
> ./build.sh
> java.lang.InstantiationException: org.apache.tools.ant.Main
>         at java.lang.Class.newInstance0(Class.java:293)
>         at java.lang.Class.newInstance(Class.java:261)
>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
> 
> How do I make 2.1.5.1 build the default target set?
> 
> 
>>The wiki explanation on the endorsed lib prob is indeed a bit strange. 
>>Note that if you use Jetty you won't have this problem.
> 
> 
> I'd settle for being able to build 2.1.5.1 first.
> 
> ///Peter


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message