cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leszek Gawron <lgaw...@mobilebox.pl>
Subject Re: Problems on JBoss 4.0 release version
Date Mon, 27 Sep 2004 07:26:57 GMT
Upayavira wrote:
> Steinar Rune Eriksen wrote:
> 
>> I've been using Cocoon 2.1.5.1 successfully on JBoss 4 RC1 and RC2 for 
>> a while. Very few issues at all actually. I just had to swap the 
>> Castor versions and put commons-logging into jboss/server/default/lib  
>> and it worked fine.
>>
>>
>> However, on JBoss 4. final release I get some more serious problems. 
>> It complains about org/apache/log/Logger not found, and of course this 
>> JAR will want a lot of other dependent Jars so it becomes a bit more 
>> messy to handle/install.
>> Anyone else experienced the same, and found a simple way around it?
> 
> 
> I something similar using Jetty 5.0, which I suspect is a part of 
> JBoss4. A problem to do with logging. I'd suggest mentioning it on the 
> dev list, but do quote a full stack trace, as that will help a lot.
> 
> My solution I'm afraid was to go back to Jetty 4.2.
Also had loggers problem. Jetty 5.0 uses commons logging and that is the 
source of the problem.

Maybe this would help (haven't tried - just found on wiki):

add 
-Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Log4JLogger 
to the command line.

add
     <init-param>
       <param-name>force-property</param-name>
       <param-value>
     org.apache.commons.logging.Log=org.apache.commons.logging.impl.LogKitLogger
       </param-value>
     </init-param>

to web.xml

I was able to run jetty with 
org.apache.commons.logging.Log=org.apache.commons.logging.impl.LogKitLogger on 
command line but then LogKitLogger had no config and logged everything in 
DEBUG - nightmare :)

I am still with Jetty 4.2

-- 
Leszek Gawron                                      lgawron@mobilebox.pl

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message