cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz "Goliatus" Taρczyk <golia...@warsztat.pac.pl>
Subject Re[3]: [XSP, ESQL, MySQL 4.1 UTF-8]Problem with special characters
Date Fri, 27 Aug 2004 12:57:13 GMT
Witaj gounis,

  I still can't get it work. Actually I did:

  1. added: "useUnicode=true&amp;characterEncoding=ISO-8859-2" in
  cocoon.xconf

  2. added set-encoding action

  3. set xml and html seralizer encoding to UTF-8

  4. set my db default encoding to latin2

  What else do I have to do? I still get "?" instead of special
  character.

W Twoim liœcie datowanym 27 sierpnia 2004 (14:31:43) moΏna przeczytaζ:
gog> i cant setup web.xml succesfull so i use an alternative approach

gog> i have as first map into my pipeline

gog> 				<map:act type="set-encoding">
gog> 					<map:parameter 
gog> name="form-encoding" value="UTF-8"/>
gog> 				</map:act>


gog> offcourse you need to declare this acction in <map:actions>

gog> puting:

gog> <map:action name="set-encoding"
gog> src="org.apache.cocoon.acting.SetCharacterEncodingAction"/>

gog> i dont know why after a cocoon version is missing from the defautl
gog> sitemap.xml

gog> btw t
gog> he class
gog> org.apache.cocoon.acting.SetCharacterEncodingAction still 
gog> exist


gog> with all this i am able to bost greek charakters and store them in mySQL



gog> -- stavros

-- 
Pozdrowienia,
 Grzegorz                            mailto:goliatus@warsztat.pac.pl


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message