cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@upaya.co.uk>
Subject Re: xindice1.1b4 + cocoon-2.1.5 lost collections
Date Thu, 01 Jul 2004 08:03:33 GMT
Rui Alberto L. Gonçalves wrote:

>Hi all,
>I'm trying to use xmldb cocoon block. Things are ok while tomcat
>is up, but after shutdown and restart tomcat, data inserted
>in the database is lost. Directories structure remains in the
>file system, but documents are no longer visible to Xindice.
>
>I've already searched xindice mailing list and I found some
>posts related to this problem, but none of them helps to solve
>the problem.
>
>Does anyone had a similar problem using xindice embed with 
>cocoon?
>
>Many thanks.
>
Are you using the Xindice command line tools too? Xindice databases must 
only be accessed by one JVM at a time. Thus if you use it in servlet 
mode, that is your one JVM - everything else talks to the servlet. If 
however you use embedded mode within Cocoon, that makes Cocoon your one 
JVM. If you start accessing a database with the command line tools while 
Cocoon is running, you will find symptoms like you describe - 
collections that you added disappearing, etc.

Hope that helps.

Upayavira

when in embedded mode must only



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message