cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From will.durr...@digitalsteps.com
Subject Re: Problems running Cocoon 2.1.5 on Websphere 5.1
Date Wed, 16 Jun 2004 12:51:27 GMT
I've tried running it using ParanoidCocoonServlet but without any change. 
I've also tried setting both the ear and war classloaders to PARENT_LAST, 
but this produces a java.lang.NoClassDefFoundError for 
org/apache/jcs/engine/control/CompositeCacheManager when trying to run any 
of the samples. Returning the classloader settings back to PARENT_FIRST 
just produces:
java.lang.NoSuchMethodError: org.mozilla.javascript.NativeJavaPackage: 
method <init>(Ljava/lang/String;Ljava/lang/ClassLoader;)V not found

Any further help much appreciated

Will


On 09.06.2004 12:35, will.durrant@digitalsteps.com wrote:
> I'm having problems running Cocoon 2.1.5 on Websphere 5.1. The first 
> problem is that I can't build cocoon with my java_home set to point at 
> IBM's jdk. I can get round this by using sun's jdk but I'm not sure if 
> trying to run it using a different jdk than that which it was compiled, 
is 
> a bad mistake? 
> The built war file successfully deploys to Websphere but upon running 
many 
> of the samples I get either:
> - ResourceNotFound exception : 
> org.apache.cocoon.ResourceNotFoundException: No pipeline matched 
request: 
> welcome
> 
> Or for other samples I get javascript related exceptions such as :
> - org.mozilla.javascript.JavaScriptException: 
> java.lang.UnsupportedOperationException: getWidget(id) got deprecated 
from 
> the API. 
> - Error 500: org.mozilla.javascript.NativeJavaPackage: method 
> <init>(Ljava/lang/String;Ljava/lang/ClassLoader;)V not found 

That should be a problem with our patch version of the Mozilla Rhino 
package. I'm not that familiar with classloader issues but does it work 
if you use the ParanoidCocoonServlet?

It's one of the first entries in web.xml. Change 
<servlet-class>org.apache.cocoon.servlet.CocoonServlet</servlet-class> 
to 
<servlet-class>org.apache.cocoon.servlet.ParanoidCocoonServlet</servlet-class>

Joerg



Mime
View raw message