cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Latty" <joe.la...@tias.com.au>
Subject RE: Tomcat and logkit conflicts
Date Thu, 01 Jul 2004 06:35:44 GMT
I have tried synching all of the commons-logging jar's but I still have
problems. There is a commons-logging-api.jar date 18-5-2004 (18 May
2004) that comes packaged inside the tomcat bin directory. 

Whilst cocoon ships with commons-logging-1.0.3.jar date 29-6-2004 (29
June 2004). 

I have tried changing the jar's in both locations to commons-logging.jar
and commons-logging-1.0.3 and commons-logging-1.0.4 with
commons-logging-api.jar and a host of other configurations.

But still I get many errors. We have a few different apps running on the
tomcat server however it is only the cocoon app that brings about the
errors.

-----Original Message-----
From: Antonio Gallardo [mailto:agallardo@agssa.net] 
Sent: Thursday, July 01, 2004 12:56 PM
To: users@cocoon.apache.org
Subject: Re: Tomcat and logkit conflicts

Hi Joe:

This seems to be a problem in commons-logging and not in LogKit. Check
if
you have diferent versions or older versions of the commons-logging-jar.

Best Regards,

Antonio Gallardo


Joe Latty dijo:
> I am constantly having conflicts within tomcat, all seem to center
> around the logging (logkit?).
>
> My cocoon application is contained in its own context (all jars in
> WEB-INF/lib) nothing in tomcat shared or common. However if I add my
> application the manager app in tomcat does not work with the following
> error (or variations on this).
>
> org.apache.commons.logging.LogConfigurationException:
> org.apache.commons.logging.LogConfigurationException:
> java.lang.ClassNotFoundException:
> org.apache.commons.logging.impl.LogKitLogger
>
> but my cocoon app works. Whereas if I remove the cocoon app (context)
> then tomcat fires up fine and the manager app works.
>
> Has anyone else experienced this?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message