cocoon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Coboos <cromo...@gmx.net>
Subject Brake > in output of HTMLSerializer, Why?
Date Mon, 14 Jun 2004 14:48:12 GMT
Hello,

I'am using JXTemplates to generate dynamic output. In these templates I 
need XHTML-Entities like &amp; oder &nbsp;. To use these entities I had 
included the DOCTYPE:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

But if I include the DOCTYPE, the output of the HTMLSerializer show 
every time a brake > on the left top. Why? If I'am using the 
XHTMLSerializer all works fine, but I need the HTMLSerializer because 
the XHTMLSerializer shows empty textareas as <textarea/> which many 
browser misinterpretes.

My Template looks like:

<?xml version="1.0" encoding="ISO-8859-1" ?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns:jx="http://apache.org/cocoon/templates/jx/1.0">
<head>
<title>Foo &amp; Bar</title>
</head>
<body>
    Some text...
</body>
</html>

For me it is a very big problem because I need the XHTML entities 
without using the XHTMLSerializer.

Thank you!

Regards
Stephan

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@cocoon.apache.org
For additional commands, e-mail: users-help@cocoon.apache.org


Mime
View raw message